Cara Mengamankan Mikrotik Apabila Menggunakan IP Publik

Cara Mengamankan Mikrotik Apabila Menggunakan IP Publik

 




Cara Mengamankan Mikrotik Apabila Menggunakan IP Publik - Seperti namanya, IP Publik tentunya IP yang dapat diakses melalui jaringan publik atau familiarnya disebut dengan internet. Dengan bisanya diakses melalui internet, tak jarang suatu IP Publik terserang DDOS maupun Brutoforce. 

Suatu jaringan yang baru pertama kali online, tentu sudah siap dihadang oleh Bot otomatis yang tersebar di internet. DDOS sendiri merupakan serangan yang bertujuan agar situs tujuan overload dan mengalami downtime. Sedangkan Brutoforce bertujuan untuk mengetahui username dan password login ke server, dengan mengirimkan random user dan password familiar secara otomatis.

Lantas, bagaimana cara mencegahnya?

Ada beberapa cara basic namun epic untuk mencegah adanya DDOS maupun Brutoforce.

Pertama, tentu merubah password login mikrotik dengan password yang mudah diingat sendiri, namun tidak dengan orang lain. Berikut cara merubahnya

Pada Winbox, masuk pada menu System > Users


Tekan tombol + dan buatlah user baru, Klik Apply dan OK. Jangan lupa disable / Hapus User default pada mikrotik.


Kemudian masuk ke menu IP > Services 



Disable port yang tidak digunakan, seperti SSH dan Telnet. Ubah port default masing-masing service.



Baik, dua cara tersebut sudah lebih dari cukup untuk mengantisipasi adanya serangan dari luar jaringan. Bisa juga ditambah dengan hanya bisa diakses melalui IP tertentu, ataupun drop paket yang masuk secara terus menerus.

Kalaupun masih ada, dengan keterangan gagal login seperti gambar dibawah, bisa diabaikan saja, ataupun menambahkan script drop paket apabila diperlukan.


Namun tenang saja, perwiramedia.com sudah mengupayakan pengamanan akunmu, dan jangan sungkan untuk berkonsultasi ke admin apabila ada kendala.

Sekian, dan jangan lupa order IP Publiknya ya , ehehe :)

Cara Konfigurasi VPN pada Jalur Loadbalance

Cara Konfigurasi VPN pada Jalur Loadbalance

 


Cara Konfigurasi VPN pada Jalur Loadbalance - Sebelum melangkah lebih jauh, tentu kita perlu berkenalan terlebih dahulu dengan loadbalance itu sendiri. Dari kata Load and Balance, load berarti memuat / memproses, dan balance berarti seimbang. Sehingga dapat diartikan loadbalance merupakan suatu metode pemrosesan traffic yang dibagi sama rata.

Lantas apa hubungannya loadbalance dengan vpn perwiramedia?, mengapa perlu di route ke salah satu isp?. 

Masih ingat, konfigurasi loadbalance ?, pada konfigurasi tersebut, masing-masing traffic dipetakan dan diarahkan ke sumber internet yang ada. Sama halnya dengan traffic lain, traffic vpn di perwiramedia tentu perlu dipetakan dan diarahkan.

Sebagai contoh, apabila vpn di perwiramedia tidak diarahkan. 
Ketika ada traffic vpn masuk ke server melalui ISP A, kemudian keluar melalui ISP B. Maka, koneksi L2TP akan terputus. Biasanya ditandai dengan Terminating - Session Closed untuk keterangan pada log mikrotik.

Untuk menghindari hal tersebut, maka perlu di route ke gateway salah satu ISP. Berikut saya gambarkan topologi jaringan yang memiliki konfigurasi loadbalance dan tentunya terpasang VPN dari perwiramedia.com .




Dari topologi diatas, terdapat dua ISP dengan gateway 192.168.1.1 dan 192.168.10.1 . Yang di loadbalance pada server terpisah dengan server distribusi. Dan terdapat VPN Perwiramedia pada server distribusi. 

Bagaimana cara meroute VPN ke salah satu ISP?, dan di server mana ?

Baik, untuk meroute VPN tentu dilakukan di server loadbalance. Dan route yang perlu dilakukan adalah meroute gateway VPN ke gateway salah satu ISP. Berikut contohnya.

VPN yang saya contohkan adalah VPN IP Publik Server Indonesia dari perwiramedia. dengan gateway 41.216.185.4.

Note : Gateway bisa dilihat di active services clientarea.perwiramedia.com . atau sama dengan connect to pada dial l2tp.



Apabila saya akan meroute VPN ke ISP A, maka berikut caranya.

1. Pertama tentu buka aplikasi Winbox.

2. Masuk ke menu IP > Routes



3. Tekan tombol + kemudian klik Apply dan OK



Note :

Dst address : diisi gateway dari VPN perwiramedia

Gateway : diisi gateway dari salah satu ISP


Pastikan status routenya active  dan reachable. Dan konfigurasi route ke salah satu isp telah selesai. :)

Tutorial Mengonlinekan Web Server Menggunakan IP Publik Dari Perwiramedia

Tutorial Mengonlinekan Web Server Menggunakan IP Publik Dari Perwiramedia

Tutorial Mengonlinekan Web Server Menggunakan IP Publik Dari Perwiramedia - Setelah selesai melakukan konfigurasi pemasangan ip publik pada server. Selanjutnya kita perlu menambahkan beberapa langkah lagi untuk konfigurasi port forwarding. 





Port Forwarding merupakan layanan yang dapat mengakses perangkat dari jarah jauh dengan memanfaatkan port tertentu yang dibuat sesuai keinginan pemilik IP Publik.

Langkah pertama ialah, buka terminal pada winbox, kemudian modifikasi script dibawah ini sesuai ip publik, port dan alamat tujuan :

/ip firewall nat add chain=dstnat dst-address=41.216.186.100 protocol=tcp dst-port=80 action=dst-nat to-addresses=192.168.1.5 to-ports=5774



Dari script diatas perlu diganti inputannya seperti :
  • dst-adress= ip publik yang dimiliki dari perwiramedia
  • dst-port= port yang ingin dibuat(bebas)
  • to-addresses= alamat ip perangkat yang ingin di akses menggunakan port forwarding
  • to-port= port default dari aplikasi dapodik, yaitu 5774

Apabila sudah, maka web server sudah bisa diakses melalui jaringan internet, silahkan ketikkan alamat ip publik pada browser. FYI, script diatas bisa diedit dan ditambahkan untuk aplikasi lain, seperti ERapor, MPD dan lain sebagainya.



Selamat, Mengonlinekan Web Server Menggunakan IP Publik Dari Perwiramedia , telah selesai.

Cara Mendapatkan Trial Gratis Layanan IP Publik, VPN Remote dan Mikhmon Online dari Perwiramedia Selama 3 Hari

Cara Mendapatkan Trial Gratis Layanan IP Publik, VPN Remote dan Mikhmon Online dari Perwiramedia Selama 3 Hari

Cara Mendapatkan Trial Gratis Layanan IP Publik, VPN Remote dan Mikhmon Online dari Perwiramedia Selama 3 Hari - Untuk mendapatkan trial gratis dari perwiramedia.com perlu dilakukan beberapa langkah sebagai berikut :



Pertama tentunya melakukan registrasi di https://clientarea.perwiramedia.com/register , agar terdaftar sebagai pengguna.



Isi data email, password, nama lengkap dan juga nomor whatsapp yang aktif agar bisa dihubungi oleh admin. Selanjutnya klik Daftar Akun.



Cek email untuk mengaktivasi akun, apabila di halaman utama tidak ada, bisa di cek di folder spam.


Setelah menekan tombok link aktivasi, kemudian akan diarahkan ke laman login clientarea kami. Silahkan masukkan email dan password yang telah dibuat tadi.



Pada dashboard pilih layanan yang ingin ditrial secara gratis.


Klik pesan sekarang untuk memilih produk trial.


Contoh Trial IP Publik

Pada Produk pilih Trial IP Publik



Contoh Trial VPN Remote

Pada Produk pilih Trial VPN Remote

Port diisi port tujuan untuk di remote : Misal port winbox di 8291 ataupun web di 80. Apabila port tujuan sudah dicustom, maka samakan dengan port custom tersebut.



Contoh Trial Mikhmon Online

Pada Produk pilih Trial Mikhmon Online

Subdomain diisi sesuai keinginan, dengan catatan tidak boleh menggunakan spasi ataupun tanda baca.



Setelah dilakukan pemesanan, kemudian hubungi admin untuk melakukan aktivasi layanan trial.


Apabila sudah di aktivasi oleh admin, dial l2tp otomatis ada di active services. 


Selanjutnya untuk tutorial pemasangan, bisa baca artikel lain ya di docs.perwiramedia.com

Tutorial Mengubah Nama ISP Saat Speedtest Dengan VPN IP Publik

Tutorial Mengubah Nama ISP Saat Speedtest Dengan VPN IP Publik

Tutorial Konfigurasi Pengalihan Nama ISP Saat Speedtest Menggunakan IP Publik dari PerwiramediaSetelah selesai melakukan konfigurasi pemasangan ip publik pada server. Selanjutnya kita perlu menambahkan beberapa langkah lagi untuk Pengalihan Nama ISP Saat Speedtest.

Mengganti Nama ISP Speedtest

Langkah pertama buatlah address list untuk IP lokal / IP private, bisa diisi sesuai IP Address yang digunakan  atau bisa diisi lengkap seperti dibawah ini.


/ip firewall address-list
add list="private-lokal" address=0.0.0.0/8
add list="private-lokal" address=10.0.0.0/8
add list="private-lokal" address=100.64.0.0/10
add list="private-lokal" address=127.0.0.0/8
add list="private-lokal" address=169.254.0.0/16
add list="private-lokal" address=172.16.0.0/12
add list="private-lokal" address=192.0.0.0/24
add list="private-lokal" address=192.0.2.0/24
add list="private-lokal" address=192.168.0.0/16
add list="private-lokal" address=198.18.0.0/15
add list="private-lokal" address=198.51.100.0/24
add list="private-lokal" address=203.0.113.0/24
add list="private-lokal" address=224.0.0.0/3

Langkah berikutnya yaitu menambahkan lagi untuk speedtest, silakan diisi dengan alamat ip atau nama domain dari speedtest yang dipakai. Atau bisa saja menggunakan beberapa list speedtest yang sudah saya siapkan, silakan tinggal di copy paste saja script pada terminal winbox.

/ip firewall address-list

add address=yougetsignal.com list=speedtest

add address=xmyip.com list=speedtest

add address=www.yougetsignal.com list=speedtest

add address=expressvpn.com list=speedtest

add address=www.expressvpn.com list=speedtest

add address=whatismyip.net list=speedtest

add address=speedtestcustom.com comment=whatismyip.net list=speedtest

add address=income.speedtestcustom.com comment=speedtestcustom.com list=speedtest

add address=iplocation.net comment=income.speedtestcustom.com list=speedtest

add address=www.iplocation.net comment=iplocation.net list=speedtest

add address=www.astrill.com comment=www.iplocation.net list=speedtest

add address=www.privateinternetaccess.com comment=www.astrill.com list=speedtest

add address=mxtoolbox.com comment=www.privateinternetaccess.com list=speedtest

add address=ifconfig.co comment=mxtoolbox.com list=speedtest

add address=whatismyip.org comment=ifconfig.co list=speedtest

add address=www.goldenfrog.com comment=whatismyip.org list=speedtest

add address=www.mxtoolbox.com comment=www.goldenfrog.com list=speedtest

add address=www.ultratools.com comment=www.mxtoolbox.com list=speedtest

add address=www.ip-adress.eu comment=www.ultratools.com list=speedtest

add address=iplogger.org list=speedtest

add address=www.vermiip.es list=speedtest

add address=www.purevpn.com list=speedtest

add address=www.whatismybrowser.com list=speedtest

add address=zenmate.com list=speedtest

add address=www.ipchicken.com list=speedtest

add address=bittrex.com list=speedtest

add address=whatismyip.li list=speedtest

add address=www.ipburger.com list=speedtest

add address=cbn.net.id list=speedtest

add address=whatismyip4.com list=speedtest

add address=www.inmotionhosting.com list=speedtest

add address=nordvpn.com list=speedtest

add address=wolframalpha.com list=speedtest

add address=cactusvpn.com list=speedtest

add address=www.cactusvpn.com list=speedtest

add address=m.wolframalpha.com list=speedtest

add address=ipcow.com list=speedtest

add address=whatismycountry.com list=speedtest

add address=passwordsgenerator.net list=speedtest

add address=att-services.net list=speedtest

add address=wtfismyip.com list=speedtest

add address=whatismyip.network list=speedtest

add address=ipinfo.info list=speedtest

add address=encodable.com list=speedtest

add address=www.overplay.net list=speedtest

add address=myipaddress.com list=speedtest

add address=www.myipaddress.com list=speedtest

add address=whoer.net list=speedtest

add address=whatismyip.com list=speedtest

add address=www.speedtest.net list=speedtest

add address=c.speedtest.net list=speedtest

add address=www.ipleak.net list=speedtest

add address=ipleak.net list=speedtest

add address=whatismyipaddress.com list=speedtest

add address=whatismyip.host list=speedtest

add address=bearsmyip.com list=speedtest

add address=check-host.net list=speedtest

add address=hide.me list=speedtest

add address=ipv6test.hide.me list=speedtest

add address=ipleak.com list=speedtest

add address=www.perfect-privacy.com list=speedtest

add address=perfect-privacy.com list=speedtest

add address=www.whatsmyip.org list=speedtest

add address=whatsmyip.org list=speedtest

add address=nperf.com list=speedtest

add address=whatismyip-address.com list=speedtest

 

 Address list diatas adalah address list umum yang admin ketahui, jika masih ada yang belum ditambahkan silakan ditambahakan sendiri sesuai kebutuhan.

Address list private-lokal dan speedtest digunakan untuk membuat mark-routing pada mangle sehingga dapat digunakan pada ip routes.

Silakan copy paste script dibawah ini untuk membuat mark-routing.

/ip firewall mangle add action=mark-routing chain=prerouting comment=VPN dst-address-list=speedtest new-routing-mark=TrafikSpeedtest passthrough=no src-address-list=private-lokal

Setelah membuat marking untuk speedtest langkah selanjutnya yaitu mengalihkan trafik sesuai marking tadi ke interface VPN IP Publik, pastikan sudah memesan ip publik dan sudah di konfigurasi dial L2TP, jika belum bisa melihat disini.

Konfigurasi VPN IP Publik L2TP

Berikut script untuk mengalihkan speedtest sesuai marking yang sudah dibuat.

/ip route add check-gateway=ping comment=speedtest distance=1 gateway="[interfaceippublik]" routing-mark=TrafikSpeedtest

[interfaceippublik]= disesuaikan dengan interface l2tp client ip publiknya.

Langkah terakhir tambahkan konfigurasi nat masquerade pada interface l2tp ip publiknya.
/ip firewall nat add action=masquerade chain=srcnat comment=VPN out-interface="[interfaceippublik]
[interfaceippublik] = disesuaikan dengan interface l2tp client ip publiknya.

Tutorial mengubah nama isp saat speedtest telah berhasil, silakan lakukan pengujian, jika masih ada yang kurang jelas silakan ditanyakan ke admin.




Tutorial Konfigurasi Port Forwarding Menggunakan IP Publik dari Perwiramedia

Tutorial Konfigurasi Port Forwarding Menggunakan IP Publik dari Perwiramedia


Tutorial Konfigurasi Port Forwarding Menggunakan IP Publik dari Perwiramedia - Setelah selesai melakukan konfigurasi pemasangan ip publik pada server. Selanjutnya kita perlu menambahkan beberapa langkah lagi untuk konfigurasi port forwarding. 

Konfigurasi Port Forwarding



Port Forwarding merupakan layanan yang dapat mengakses perangkat dari jarah jauh dengan memanfaatkan port tertentu yang dibuat sesuai keinginan pemilik IP Publik.

Langkah pertama ialah, buka terminal pada winbox, kemudian modifikasi script dibawah ini sesuai ip publik, port dan alamat tujuan :

/ip firewall nat add chain=dstnat dst-address=41.216.186.100 protocol=tcp dst-port=99 action=dst-nat to-addresses=192.168.99.2 to-ports=80

Dari script diatas perlu diganti inputannya seperti :
  • dst-adress= ip publik yang dimiliki dari perwiramedia
  • dst-port= port yang ingin dibuat(bebas)
  • to-addresses= alamat ip perangkat yang ingin di akses menggunakan port forwarding
  • to-port= port default dari akses perangkat tersebut, saya menggunakan akses point tplink, dimana remote aksesnya melalui port 80 atau port web
Langkah selanjutnya ialah membuka akses remote manajemen pada masing-masing akses point(bila ada). Dikarenakan saya menggunakan Tplink Wr840 dimana perangkat tersebut membutuhkan dibukanya akses remote manajemen, maka perlu dilakukan satu perubahan konfigurasi pada akses point tersebut.



Apabila konfigurasi telah selesai dilakukan, mari kita coba untuk mengakses tplink melalui jalur internet selular / gsm. Dengan menuliskan ip publik yang dimiliki kemudian diberi tanda : dan diikuti dengan port yang telah dibuat.
IPPUBLIK:PORT = 41.216.186.100:99

 

Selamat, Konfigurasi Port Forwarding Menggunakan IP Publik dari Perwiramedia , telah selesai.



Cara Konfigurasi Mikhmon Online dari Perwiramedia

Cara Konfigurasi Mikhmon Online dari Perwiramedia

Cara Konfigurasi Mikhmon Online dari PerwiramediaSetelah proses order VPN Remote selesai, maka layanan dapat dilihat di Active ServicesNantinya terdapat berbagai informasi yang dibutuhkan untuk konfigurasi.

Cara Konfigurasi Mikhmon Online


Login pada clientarea.perwiramedia.com kemudian klik pada menu active services




Berikut merupakan informasi yang didapat pada menu Active Services


Klik pada Action Detail untuk mengetahui informasi server address, username dan password guna melakukan dial pada mikrotik.


Kemudian buka aplikasi winbox dan masuk pada menu : Interfaces > Add > L2TP CLIENT


Masukkan informasi Detail Nomor 1 pada Connect To, Nomor 2 pada User, dan Nomor 3 pada Password. Kemudian klik Apply dan OK.


Pastikkan Status dial L2tp di pojok kanan bawah ConnectedApabila sudah, maka VPN sudah terkoneksi.

Selanjutnya buka subdomain yang sudah diorder sebelumnya. 


(subdomain yang diorder).hospotkita.com 

Username : mikhmon
Password  : hotspotkita

Setelah masuk pada panel mikhmon, kemudian koneksikan mikhmon dengan MikroTik server. Langkah pertama ialah klik pada Add Router


Isi data Session Settings sebagai berikut :

Session Name : Sesuai yang diinginkan
IP MikroTik       : Sesuai informasi IP Address pada action detail pada gambar bernomor 4
Username        : Sesuai username mikrotik server
Password         : Sesuai password mikrotik server
Hotspot Name  : Sesuai yang diinginkan
DNS Name       : Sesuai yang diinginkan



Apabila data telah terisi, selanjutnya klik Save > Ping > Connect. Pastikan ketika di Ping statusnya OK agar bisa terkoneksi.


Selamat konfigurasi mikhmon online telah berhasil.









Tutorial Konfigurasi IP Publik Via Tunnel L2TP dari Perwiramedia

Tutorial Konfigurasi IP Publik Via Tunnel L2TP dari Perwiramedia

Tutorial Konfigurasi IP Publik Via Tunnel L2TP dari PerwiramediaSetelah proses order IP Publik selesai, maka layanan dapat dilihat di Active ServicesNantinya terdapat berbagai informasi yang dibutuhkan untuk konfigurasi.

Cara Konfigurasi VPN IP Publik


Login pada clientarea.perwiramedia.com kemudian klik pada menu active services




Berikut merupakan informasi yang didapat pada menu Active Services


Klik pada Action Detail untuk mengetahui informasi server address, username dan password guna melakukan dial pada mikrotik.


Kemudian buka aplikasi winbox dan masuk pada menu : Interfaces > Add > L2TP CLIENT


Masukkan informasi Detail Nomor 1 pada Connect To, Nomor 2 pada User, dan Nomor 3 pada Password. Kemudian klik Apply dan OK.


Pastikkan Status dial L2tp di pojok kanan bawah Connected. Apabila sudah, maka IP Publik sudah siap digunakan. Berikut salah satu cara menggunakannya :

Alamat pada Connect To untuk login, dapat dilihat pada gambar diatas yang diberi nomor 4


Selamat Konfigurasi IP Publik dari Perwiramedia telah berhasil.






Tutorial Konfigurasi VPN Remote dari Perwiramedia

Tutorial Konfigurasi VPN Remote dari Perwiramedia

Tutorial Konfigurasi VPN Remote dari Perwiramedia - Setelah proses order VPN Remote selesai, maka layanan dapat dilihat di Active Services. Nantinya terdapat berbagai informasi yang dibutuhkan untuk konfigurasi.





Login pada clientarea.perwiramedia.com kemudian klik pada menu active services



Berikut merupakan informasi yang didapat pada menu Active Services

Tutorial Konfigurasi VPN Remote


Klik pada Action Detail untuk mengetahui informasi server address, username dan password guna melakukan dial pada mikrotik.

Tutorial Konfigurasi VPN Remote


Kemudian buka aplikasi winbox dan masuk pada menu : Interfaces > Add > L2TP CLIENT

Tutorial Konfigurasi VPN Remote

Masukkan informasi Detail Nomor 1 pada Connect To, Nomor 2 pada User, dan Nomor 3 pada Password. Kemudian klik Apply dan OK.

Tutorial Konfigurasi VPN Remote


Pastikkan Status dial L2tp di pojok kanan bawah Connected. Apabila sudah, maka VPN Remote sudah siap digunakan. Berikut cara menggunakannya :

Alamat pada Connect To untuk login, dapat dilihat pada gambar diatas yang diberi nomor 4

Tutorial Konfigurasi VPN Remote


Selamat Konfigurasi VPN Remote dari Perwiramedia telah berhasil.